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Abstract  

Use of geographical information and GIS-tools is an important part of management and 

decision-making in governmental bodies and in the exercise of authority to solve 

environmental challenges. Building capacity in GIS is an essential part of the projects and 

activities in the Oil for Development program (OfD) supported by the Norwegian government 

and implemented by The Norwegian Environment Agency (NEA). The main focus of our work 

relates to strenghtening data and capacity for environmental management of the oil and gas 

sector. This user guide is developed to support training in GIS in the cooperating OfD-

countries to support area-based planning and sensitivity mapping.  

 

This user guide provides both theoretical knowledge in GIS and step-by-step exercises in QGIS 

to strengthen capacity in representing, processing and visualising spatial data. It is developed 

in the context of Myanmar but can also be utilised in other countries.  

 

The UN Environment Programme World Conservation Monitoring Centre (UNEP-WCMC) 

provides support to the Norwegian Environment Agency under the Oil for Development 

programme, and they are contributing in building capacity both in Myanmar and in other 

countries on how to manage and use spatial data.  

 

GIS-experts at the contractor, Norkart AS, have been responsible for the main part of this 

user guide, supported and reviewed by WCMC and NEA. Exercises and data in this user guide 

are based on spatial data from Myanmar, but it covers general GIS-techniques and practices 

and should be relevant for use in other countries.  

 

The user guide is developed for QGIS, an open source software free and open for use. 

Examples are mainly based on QGIS version 3.4 (last long term realease), but some of the 

exercises are not updated and the illustrations might not correspond to your program. NEA 

encourage use of open source software in the context of OfD to ensure sustainable use of GIS 

within restricted budgets. 

 

This is a first version of this manual and we are planning to develop it further with more 

techniques and topics in the future. Feel free to share, adapt and use this user guide, it is 

licensed with an open licence.   

 

 

 

 
  

https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
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1. Introduction to a GIS 

Geographic Information Systems (GIS) are all about spatial data. Spatial data are 

special in the sense that we deal with geometries in addition to regular data like 

text and numbers. Geometry introduces more complexity than text and numbers, 

but also more possibilities. There are some pointers that you should be aware of 

when managing spatial data. Below, we briefly go through some of the most 

important concepts step-by-step. Be aware that some topics have been simplified. 

For more details, the reader is referred to GIS and Cartographic textbooks. 

1.1 Coordinate systems 

A geometry is typically defined in a two-dimensional (2D) space. This means that we have 

coordinates that are located along a coordinate system. Typically, these coordinates are 

Latitude/Longitude, X/Y or North/East. It is only when a GIS layer has a correct definition 

that the coordinates will be placed on their actual location.  

 

GIS aims to create 2D maps from a three-dimensional (3D) world. The world is however not 

a perfect sphere—but rather like a squeezed ball, called an ellipsoid. The modelling of this 

3D shape (ellipsoid) is called a datum. Some common horizontal datums are: 

 

• WGS84: World Geodetic System 1984, used by the Global Positioning System (GPS) 

• Euref89: Newer version of WGS84, used specifically for Europe 

• Arc1960: Local African datum  

• Indian 1954: Local Asian datum for topographic mapping in Myanmar and Thailand 

(onshore).    

 

  

FIGURE Geoide, ellipsoids (source: Wikipedia) 

 

With a model of the 3D world, we can transfer a point on the 3D surface onto a 2D map. 

This process is called ‘projecting’, and uses a projected coordinate system to translate 

between 3D and 2D. A projected coordinate system is based on geographic coordinate 

system, but it is defined on a plane (the spheroid projected onto a 2D surface) and uses 

linear units (feet, meters, etc.). These systems are further explained below. 
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1.1.1 Geographic coordinate systems (three-dimensional) 

The easiest coordinate system we can use is a geographic coordinate system, which uses 

Latitude and Longitude points on a map. These spherical coordinates use angular units 

(degrees), which are measured from the Earth’s center to a point on the Earth’s surface. 

A geographic coordinate system thereby gives a position in three dimensions, as an 

intersection of the latitude, the longitude and the ellipsoid. For topographic mapping, 

geographic coordinates should always be used to get the most accurate positions.  

 

Geographic coordinate systems are usually named after the datum they are based on. The 

most common system is WGS84 (EPSG:4326) which maps directly to the ellipsoid-model. 

WGS84 is the datum used by the Global Positioning System (GPS). Since latitude and 

longitude are angles, these cannot be used directly to measure distances or area. This is 

because the length between point A (X1,Y1) and point B (X2,Y2) will be in degrees, which 

does not make sense for measurement purposes.  

 

1.1.2 Projected coordinate systems and UTM zones (two-dimensional) 

Different projections have been developed to show the geographic coordinate system on a 

2D surface. Even though the geographic coordinates are the most accurate ones, it is more 

practical to show the world as a flat surface. Coordinates in a 2D plane also makes it 

possible to do linear measurements on the map, in units such as meters or feet.  

 

The coordinates in a given datum can be presented in many different projections. There 

are four different factors that matter when making a projection: shape, area similarity, 

distance similarity and direction. Every projected coordinate system is a compromise 

between these four factors. If one of the factors is considered more than the others, this 

affects the precision of the other three. There have also been projections developed that 

try to compromise the four factors. The Universal Transverse Mercator (UTM) is well known 

and a very good example of this.  

 

The UTM system is a system of map projections that covers most of the earth’s surface. It 

divides the earth into 60 zones, each of them is six degrees in width.  

 
The UTM grid. (source: Wikipedia) 
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Each country or region often has defined a standardized coordinate system based on the 

UTM system. This will differ between each country or region. Some countries stretch over 

more than one UTM zone. For instance, Norway stretches from UTM zone 31 to 36, but 

not all zones are used on a daily basis. For national data that will be used for the entire 

country, a national standard of UTM zone 33 has been set for Norway. For measurements 

and area calculations, use the projected coordinate system that belongs to your 

national/regional standard.  

 

So, what does it really mean to take a choice of using a specific UTM zone? In the case of 

Myanmar, the local datum is the Indian 1954. The picture below shows the extent of the 

geographic coordinate system Indian 1954 (EPSG: 4239), which is a geographic 2D 

coordinate reference system suitable for use for topographic mapping in Myanmar 

(onshore) and Thailand (onshore). 

 

 

 
 

Onshore, there are two different local projections depending on where in the country you 

are: 

• Indian 1954 / UTM zone 46N – EPSG: 23946 (Myanmar - onshore west of 96°E). 

Accuracy 21 meters. 

• Indian 1954 / UTM zone 47N – EPSG: 23947 (Myanmar - onshore east of 96°E) 

Accuracy 21 meters. 
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These two local projections can be useful when working with local data in a specific region 

of the country. If you are working with spatial data or maps that stretch over larger areas, 

you should use a projection with a larger area of use. This is also important to consider 

when you want to georeference a map that covers an entire country. The UTM system 

would then be a natural choice, since it is adapted to suit larger regions than those of local 

datums. If you try to use a local projection for this, you may get a bad result. On the other 

hand, it could be a good choice if you want to georeference a local map, as the extent 

would occur within the local UTM projection. Different aspects must be considered relative 

to the trade-offs. 

 

Standard coordinate system of Myanmar 

Myanmar belongs to the UTM zones 46 and 47. The standard coordinate system is set to 

WGS 84/UTM 47N (EPSG: 32647). Most likely this is because most of the onshore area of 

Myanmar is located within this zone. 
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FIGURE. When you choose a coordinate system in QGIS, you will get a small picture in the bottom of the Coordinate 

Reference System (CRS) window, which shows the extent of the projection. 

 

1.1.3 Our recommendations 

So, what does it mean to make a choice about the UTM zones? And when should we use 

geographic coordinate systems, with latitude and longitude coordinates?  

 

When it comes to coordinate reference systems, there is no one fits all solution. You must 

adapt the choice of coordinate system to the purpose of use.  

 

When you are digitizing new objects offshore or when you do topographic mapping, 

geographic coordinates should always be used as they are most accurate. If you later want 

to use the data for analysis and measurements, make a copy of the layer and save it to a 

projected coordinate system. To avoid inaccurate measurements offshore, you should 

always use a 3D geographic coordinate system, such as WGS 84. This is also important when 

working with data that covers more than one UTM zone. If a projected (flat) surface is 

used, the locations furthest away from the center of the projection will be inaccurate. 
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In GIS analyses, measurements are often but not always an important part. If measurement 

is not part of the analysis, the most important thing is to make sure all of the datasets you 

are using have the same coordinate system. It is therefore good practice to use datasets 

in the same projected coordinate system. Then, you can be certain that the 

measurements will be correct. 

 

When making a map, you should choose a coordinate reference system that fits well with 

both the location in the world and the scale of the map. Projected coordinate systems 

based on a local datum fit well with large-scale maps, or those that show a small area in 

greater detail. Examples include guide maps, topographic maps and regional thematic 

maps.  

 

In contrast, small-scale maps show a larger area with fewer details. Examples include wall 

maps, atlas maps or small-scale thematic maps.  

 

If you are making a map of your country, you should choose the national standard projected 

coordinate system or a geographic coordinate system. On a small-scale map, add a 

geographic grid that shows the geographic coordinates in degrees. On a large-scale map, 

add a grid that shows the coordinates in linear units (decimal). This helps the user to 

orientate on the map.  
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1.2 Raster and vector data 

Map data comes primarily in two fundamentally different structures: raster and vector.  

 

Raster data are “grids” or matrices of cells, which have a defined resolution. Each grid cell has 

a value. The value can represent very different things, such as height, color, sensor value, 

observation count and so forth.  

 

Each grid cell has a predefined resolution, or level of accuracy. This means that if we “zoom 

in” too close, we lose detail. An immediate example is with satellite imagery, which are raster 

files (grid cells with color values). Consider the following example with different zoomed in 

versions of the same image: 

 

    

      

 

Vector data represents the world using points, lines and polygons. It is useful for storing data 

with discrete boundaries, such as country borders, streets, land use, biodiversity areas and 

cities. Vector data is also used to represent point observations of species occurrence. 
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1.3 Geometries 

Geometries come in different 2D and 3D forms and shapes. The most commonly used 2D formats 

include: Points, Lines, and Polygons.  

 

Often, data files are separated by the geometry type. A point consists of a coordinate pair (i.e. 

latitude and longitude coordinates). A line consists of several points. A polygon consists of 

several points and wraps around a surface, which then makes up an area.  

 

 

 

1.4 Attributes 

A spatial object consists of a geometry and a set of attributes. Attributes are data or 

information attached to the spatial object. An attribute has one value, which can consist of 

text or numbers. For instance, you can have an object type, bird_reservoir, where you would 

store a polygon representing the geographic area. Along with the geometry (polygon) you want 

to store the bird_count and last_observation_date. These are the attributes of that object. 

The values of the attributes can be different for each geometry (or polygon). 

 

 

 

1.5 File formats 

GIS data are stored in many different ways. Raster files are typically stored as image files like 

Tag Image File Formats (e.g. .tif, .geotiff) or data files like Digital Elevation Models (DEM). 

Vector files comes in more varied shapes. Here, we outline some of the most common and 

useful formats. 

 

1.5.1 ESRI shapefile (.shp) 

ESRI shapefiles are one of the most common formats for storing vector GIS data. Shapefiles 

store non-topological vector data with attribute data. A shapefile consists of several files with 

the same filename, but different file endings:  
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To work, the shapefile must have three mandatory files:  

• .shp – shape format: the feature geometry itself 

• .shx – shape index format: a positional index of the feature geometry 

• .dbf – attribute format 

 

Remember to include these three if you want to share an ESRI shapefile. The other file types 

are optional. If you also want to include the information of the coordinate system, include the 

.prj file, which is the projection format. 

 

A shapefile can only store one geometry type (i.e. point, line, polygon) at a time, so you will 

need separate shapefiles for each set of points, lines and polygons. If you are only going to read 

(not change) the contents of the shapefile, you can compress the files into a .zip package that 

can be read directly in the GIS. This is very handy! 

  

 

 

1.5.2 File databases 

File databases are modern file storage mechanisms. ESRI has one version which is called a File 

Geodatabase (.fgdb). A file database stores many tables (files) within a single file. Each table 

can have its own set of geometries and attributes. It is a more efficient mechanism than plain 

files and is also more practical when managing data. 

 

The ESRI file geodatabase is a proprietary format which can be read and to some degree 

changed. A similar but better format for QGIS is the SpatiaLite (.sqlite) file database or the 

geopackage (.gpkg) format.  

 

You should strongly consider using a file database instead of plain files for storing your data! 

 
 

1.5.3 ESRI file geodatabase (.fgdb)  

ESRI file geodatabases are ESRI’s standard database format. A file geodatabase is a collection 

of various types of GIS datasets held in a file system folder. This may include both spatial and 

non-spatial data.  
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You can easily access ESRI’s file geodatabases in QGIS, as read-only utilities. Choose <Vector> 

in the <Data Source Manager>, then <Directory> as the Source Type and <OpenFileGDB> as 

the Source. Find the folder of the .fgdb file, select it, and press <Choose folder>. 

 
 

When you then select <Add>, you will get a new box listing the layers in the database. You may 

pick layers from the list or <Select All>. If you wish to pick a few of them, click them while 

pushing the CTRL button on your keyboard. When you are happy with the selection, press <OK>. 

The layers will be added to your layers bar in QGIS. 

 

 

 

If you select <Add layers to a group>, the selected layers will be grouped under the name of 

the ESRI .fgdb. In this case, the group name will be “AOI”. In the example below, all of the 

layers have been selected, and thereby added to the new group. 
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In QGIS, ESRI .fgdb layers may be used as input layers in analyses or for spatial queries of the 

dataS, but cannot be changed. The geometries and attributes of the .fgdb objects can also not 

be changed, and it is not possible to export vector data to an ESRI geodatabase. These actions 

can only be done using ArcGIS software.  

 

If you need to change the data, export the ESRI geodatabase to a shapefile (.shp) or to a 

database format such as geopackage (.gpkg) or spatialite (.sqlite) and do the changes there.   

 

1.5.4 Structured text (.xslx or .csv) 

 

Data may also be found in spreadsheets, like Excel spreadsheets (.xslx or .csv) or similar. These 

files may contain geometry in the form of point coordinates in two columns (e.g. x/y, 

North/East, or Latitude/Longitude). 

 

 

 

These can be imported into GIS, which interprets the columns and generates points for 

each data entry. Structured text files are often in the form of .csv files, which are comma 

separated.  

 

Sometimes, it may be useful to have non-spatial files that you can connect to geometry 

objects directly in the GIS.  

 

1.5.5  Raster (.tif or .geotiff) 

Raster files are stored as image files, such as TIF or a DEM, and can be added from the <Data 

Source Manager>. For instance, of data currently available for Myanmar, there are some .TIF 

files in the ‘Biodiversity’ group (e.g. “Forest FFI”). Find these files (mark more than one file to 

add more than one at a time, while holding down the CTRL key on your keyboard), and then 

click <Add>. 
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The TIF files in this example all have defined symbology, or the style and colours used to display 

the data. The symbology has been defined in the QGIS “Layer Definition Settings”, and then 

saved as the default for each of the layers.  

If you open a raster file without a defined symbology, it will not be clear at first glance: each 

cells will have a different value, but these will not be very useful without understanding their 

meaning. To create a clear display of the raster image, you would need to define a good 

symbology based on the cell values. The symbology would depend on which kind of raster you 

are working with: for instance, the symbology used for a terrain model would not suit data 

classifying forest types.  

Note: We will dive deeper into symbology in the chapter about ‘Cartography and styling’. 

 

1.5.6 Web Map Services (WMS) and Web Feature Services (WFS) 

Many file formats are available in QGIS, but we can also load spatial data from online services, 

accessed via the internet. <WMS/WMTS> is a standard service for Web Map (Tile) Services 

(WMS) that provide information about layers, symbology and features. A WMS allows you to 

display maps and aerial photos in your GIS without having to download the data. The layers are 

displayed as rasters and, depending on the configuration of the service, can include information 

about the features or each layer’s symbology. Both the data and the aerial photos are stored 

and maintained by the organization that provides the service.  

 

A web feature service (WFS) is a standard service with additional functionality. While the WMS 

service only gives access to images of the supplier’s data, a WFS allows users to select, style 

and perform other operations with the features of the map layer. 

 
Both services use URLs to connect to and request information and features from them. You 
need to know the URL to get access to the WMS. Here is an example on how we can use services 
from Geoserver’s URL to access a WMS for Ghana: http://maps.ghanaein.net/geoserver/ows?   

http://maps.ghanaein.net/geoserver/ows?
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To add a Web Map Service (WMS) 

Open the <Data Source Manager>, select <WMS/WMTS>, and click <New>. We will click 

on <Layer>, <Add Layer>, and <Add WMS WMTS Layer>. A new window will open. In this 

window, click on <New>, give the WMS a name, and write the URL of the service 

(http://maps.ghanaein.net/geoserver/ows?) into the URL dialog, check the <smooth pixmap 

transform> checkbox, and click <OK>. A list of layers will display: choose the layers to 

load into QGIS canvas and click <Add> (see below). 

 

 

To add a Web Feature Service (WFS) 

If loading layers from a WFS, open up the <Data Source Manager>, select <WFS>, and click 

<New>. Choose a name you like, and fill the URL with the Geoserver’s URL 

(http://maps.ghanaein.net/geoserver/ows?). Click <OK> and <Connect>. A list of layers 

will display: choose the layers to load into QGIS canvas and click <Add> (see below). 

 

http://maps.ghanaein.net/geoserver/ows?
http://maps.ghanaein.net/geoserver/ows?
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MetaSearch 

In QGIS there is also a built-in plugin named Metasearch. Here, it is possible to search for 

available WMS and WFS layers. You can access it from the top menu: select <Web>, then 

<MetaSearch>. When you open it up for the first time, the first thing you need to do is to 

choose which Metadata Catalog you wish to use. Choose the one that applies to your part of 

the world, if there is one. You may get service info from the <Service Info> button under 

<Services>. When you have found the correct one, use the <Search> banner (see below). 
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2. QGIS 

In this chapter, we will dive into QGIS. You will get familiar with the interface and 

learn how to use the most important functions. 

2.1 Installing QGIS 

Install QGIS from the QGIS webpage. The easiest way is to use one of the standalone installers 

listed on the download web page. Depending on your computer’s operating system, you will 

choose the 64-bit or 32-bit version. Choose the ‘long-term release’. QGIS 3.4 has been the 

long-term release since the end of February 2019. 

  

https://qgis.org/en/site/forusers/download.html  

2.2 Interface 

 

 

QGIS consists primarily of: 

 

A control panel with tools: 

 
 
  

https://qgis.org/en/site/forusers/download.html
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The map window 

> 

 

And the Layers 

manager v 

 

 

 

In QGIS, you set the project coordinate system in the bottom right corner of the map window: 

 

 

 

 

This is where you decide what coordinate reference system (EPSG 

coordinate number) will be presented in the status bar and how the 

layers are shown or projected. Double click the coordinate numbers 

to reach the project properties.  

 

The interface is very customizable, with variations between versions 

of QGIS. However, the main components are always there. To get an 

overview of which toolbars and panels are activated, right click in 

the grey area of the <Control Panel>. Activate/deactivate 

<Toolbars> and <Panels> by a left click (see right). 
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2.3 Coordinate systems in QGIS 

When you open up QGIS for the first time, there are some settings you need to do.  

 

From the menu bar, go to <Settings>, select <Options> and then <CRS>. You will get this 

window: 

 
 

Set the default Coordinate Reference System (CRS) for new projects  

Choose the coordinate reference system (CRS) that is standard for your country, or the data 

you mainly will be working with. The CRS selected will depend on whether you will be working 

mainly with geographic or projected data.  

 

If you will be working mainly with registration of new data, use a geographic coordinate 

system. For example, you may use the global default CRS: EPSG 4326 – WGS84. This is especially 

important if you are working offshore, since the UTM zone standards are optimized for mapping 

onshore.  

 

If you will be working mainly with projected coordinate system you should choose the 

standard projected coordinate system of your country/region. For Myanmar this would be 

EPSG 32647 – WGS 84/ UTM zone 47N.  
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2.4 Add data 

Layers can be added to your QGIS 

project from the <Data Source 

Manager>, the <Browser Panel> or 

from the <Menu Layer/Add Layer>. 

The <Data Source Manager> can be 

activated from this tool button in the 

control panel:  

  

 

…or from the <Browser Panel>, or 

from <Layer>, then <Add Layer> 

(see right). 

 

 

 

 

 

When you add a layer, it is added to 

the layer manager. The order of the layers directly represents 

the drawing order in the map window. 

 

 

 

Layers can be grouped together by selecting them, pressing the CTRL key on the keyboard while 

selecting each layer. Then, right click on the selected layers (while still holding CTRL), and 

select <Group>.  

 

You can also rename the layers. Note that this does not change the underlying datasets—only 

the name in QGIS.  

 

To look at the attribute data you can right click on a layer and select <Open Attribute Table>, 

which brings up a table where all of the data (or ‘attributes’) are displayed with one line per 

object. 
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You can actually select and edit the data directly within the attribute table.  

2.5 Layer transformations 

From the menu bar, go to <Settings>, select <Options> and then <CRS>. You will get this 

window: 

 

In this window, there is also a setting that applies to new layers: <CRS for new layers>. When 

you use layers that do not have a CRS, you need to define how QGIS responds to them. Here 

you find three options: <Prompt for CRS>, <Use project CRS> and <Use default CRS>.  
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In the <Layer properties>, which you reach by right clicking the layers, the coordinate system 

for each layer is defined. This must correspond to the actual coordinate reference system (CRS) 

of the layer. Note: Changing the definition of the layer in the layer properties will not 

change the coordinate system of the layer, and would result in placing the layer in the 

wrong location. But, as long as the layer coordinate definition is correct, you can change the 

project definition system and QGIS will project the layers ‘on-the-fly’.  

 

What is ‘on-the-fly’, and why does it matter? 

When you are using GIS, the software will try to translate between different coordinate 

systems ‘on-the-fly’ and behind the scenes. ‘On-the-fly’ means that QGIS is showing a layer 

in a different coordinate system than it is actually in. Pay attention to this! This means 

that you will view the layer in another coordinate system, but it will NOT actually be re-

projected. You must transform the dataset to your desired coordinate system for any 

analysis. Do not do your analysis on-the-fly.  

 

Note: In QGIS, ‘on-the-fly’ re-projection is automatically enabled (since QGIS 3 was 

released). 
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To re-project one of your layers into 

another coordinate system:  

If two datasets are not referenced to the 

same geographic coordinate system, you 

may need to perform a geographic 

transformation. The method converts 

coordinates between two geographic 

coordinate systems. The best practice is to 

always try to have all your data in the same 

coordinate system—preferably the 

national/regional standard. 

 

Transformation of a dataset in QGIS is made 

by exporting the layer and saving it in a new 

coordinate system.  

 

1. Right click on the layer in the <Layer 

Manager>, select Export > Save 

features as. (See right) 

2. Choose a format (e.g. ESRI 

Shapefile), and complete the <File 

name>. In <CRS>, select your 

preferred coordinate system. When 

you then save the layer, it has been 

stored in your preferred coordinate 

system. (See right) 

 

Tip: If you are working with two CRS 

versions for the same layer, include the 

CRS code or name in the layer name.  

 

Note: This method may also be used to 

save only a selection of features from 

another layer by checking the <Save only 

selected features> box. See Section 

2.6.1 for more information.  
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Another way to re-project a layer is to use the function <Reproject>. Select Vector > Data 

Management Tools > Reproject Layer. 

 

 

 

Choose the <Input Layer> and the <Target CRS>. You may either create a temporary re-

projected layer or save the output re-projected layer to a new file. The re-projection algorithm 

creates a new layer with the same features as the input layer, but re-projected to a new CRS. 
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2.6 Selection 

You can select objects in a layer using different 

methods.  

 

The easiest is to use the <Selection> tool: 

 

 

You can also select directly by clicking rows in the 

attribute table. Select multiple rows by holding down 

the CTRL key on your keyboard, and clicking each row. 

 

An advanced selection is made by using the <Select features using an expression> tool (see 

below). Here, we can select all objects which fit a criterion we set through an expression. For 

example, we can select attributes from the layer “ne_10m_admin_0_map_units” using the 

expression: 

"gdp_md_est" > 10000 

 

This translates into: “select all objects with “gdp_md_est” greater than 10000”. 

 

Notice that the rows in the attribute table as well as the objects in the map window are 

immediately highlighted with the matching rows. 
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There are many functions available in the <Select by expression> window, which may be 

overwhelming for a beginner. To start, <Fields and Values> and <Operators> are good 

functions to become familiar with. By clicking each, you will you receive some information 

about it in the right window. 

 

Fields and Values contains a list of fields from the layer. You may either write your 

expression directly in the expression field, or you may use the function and alternatives, to 

select fields. 

  

Selecting by one attribute 

You want to select the mangrove areas with an area larger or equal to a certain value.  

1. Select the attribute “AREA_KM2”.  

2. Open up the <Fields and Values> to get the list of attributes.  

3. Double-click the attribute you want (i.e. AREA_KM2) to add it to the expression.  

4. Open up <Operators> to get the full list of options (i.e. some operators are available 

on the top of the expression window, but not all of them!).  

5. Double-click >=. The operator is added to the expression window.  

6. Return to <Fields and Values>, select AREA_KM2, and find the <Values> field.  

7. When selecting a value, you may either search for a specific value, list all unique 

values, or get 10 samples. If you have a large dataset, it may take some time to list 

all unique. Double-click the value under <Values>, or write in a value in the 

<Expression> field.  

8. Click <Select features>, close the window and go back to the attribute table.  

9. To show only the selected features, left-click in the bottom corner, and then choose 

<Show selected features>. You have selected the features with an area larger than 

or equal to 50. 
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Selecting by more than one attribute  

Another example is selection based on values for two different attributes. Let’s say we want 

to select all the Block types that are “Offshore,” which are operated by “Shell Myanmar” (see 

image below).  

 

1. We make one expression for each of the attributes, to select the preferred values. 

For the first attribute (condition a): add “BlockType1” to the <Expression> field, 

and make it = ‘Offshore.’ (Note: Single quotations for the second part!)  

2. For the second attribute (condition b): add “Operator” and make it = ‘Shell 

Myanmar Energy (Pte) Ltd.’  

3. Then, add AND between the two expressions to select both of them. This will return 

those blocks where both condition ‘a’ and ‘b’ are true. 

 

 
 

4. If we change the operator to OR, we select all features which have either condition 

‘a’ OR condition ‘b’ (see below). 
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5. You can also use the operator IN to list values (i.e. “Operator” IN ( ‘Shell Myanmar 

Energy (Pte) Ltd.’, ‘Reliance Industries Ltd.’, . . .), which may also be combined 

with an AND syntax and another value. 

  

 
 

2.6.1 Save selection 

In the previous chapter, we looked at how you can select the features (objects) you are 

interested in by clicking or by using expressions. When you have made your selection, you can 

extract the selected features into a new datafile and layer. If you want to manage this data, 

you can then import the new layer into your file database. 

  

1. Right click the layer you selected from in the layer manager and click Export > Save 

Features As: 

 

 

 

2. Choose the path to save the temporary selection file to. According to the work routines 

‘best practices’ described in the appendix, the path for the temporary files would be 

like this:  

 

/projects/projectname/project_data/temp/”filename”.shp 

 

We choose to save the temporary file as an ESRI shapefile for convenience. Note: You 

need to check the checkbox “Save only selected features”. This is the key to export 

our selected features (see next page).  
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You have now saved the selected data in an ESRI shapefile which is also automatically added 

to the layer manager.  

2.7 Excel handling 

2.7.1 From Excel to QGIS 

Often, GIS data are delivered in a table or an Excel spreadsheet. If the data has a list of 

latitude/longitude coordinates, you can import it into QGIS.  

1. First, examine your tabular data source. The file must have columns for the X and Y 

coordinates.  

2. To import the data to QGIS, save it as a text file: use the “Save as” function in Excel, 

and save as a Tab Delimited File or Comma Separated Values (CSV) file.  

3. Open it up in a text editor such as Notepad to look at the contents. 

 

4. In QGIS, open up the <Data Source Manager> window and select <Delimited text>.  
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5. Specify the path to the text file in <File name>. Check for the correct <File 

Format>. For ‘custom delimiters’, you must also choose how data are separated in 

the text file. If you are unsure, you can try different options. When you have chosen 

the correct one, the data will look like a table in the <Sample data> preview.  

6. Choose <Point coordinates> under <Geometry Definition>, and provide in the fields 

for the X (“Lon”) and Y (“Lat”) coordinates.  

7. Choose coordinate system (in <Geometry CRS>) and then <Add> the layer.  

 

 

 

The delimited text layer will be added to the layer manager, and is displayed as points in the 

map window. 
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2.7.2 From QGIS to Excel 

To get data from an attribute table of a QGIS layer to Excel is quite easy. The main way to do 

this is by right clicking on the layer with the attribute table you want to export and click Export 

> Save Features As. Select the format as MS Office Open XML spreadsheet [XLSX]. Choose 

where you want to save it and give it a <File name>, then click <OK>.  

 

 
 

Alternatively, go into the attribute table of your preferred layer. Mark all rows by clicking the 

upper left corner. The marked rows turn blue. Press CTRL + C. All the cells are copied to the 

clipboard.  
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Open up Excel and press CTRL + V. The chosen rows are pasted into Excel. As you can see, 

there is a column that describes the geometry. Delete this column to get a more readable table.  
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2.8 Joins  

Joins transfer attributes from one layer to another based on their spatial relationship (2.8.1 

Spatial joins) or a common attribute (2.8.2. Vector joins), joining the two tables together. 

The input layer and join layer do not need to have the same geometry type to be able to join 

(e.g. a vector layer may be joined with a non-spatial layer, such as a table). 

2.8.1 Spatial joins 

To do a spatial join in QGIS, use the top menu <Vector/Data Management Tools> and open the 

function called <Join Attributes by Location>. Fill in the:  

 

• <Input layer>, or the layer you want to add data to;  

• <Join layer>, or the data being added; and  

• <Geometric predicate>, or the spatial criteria (for example the intersection between 

the two layers) that is applied to select the values from the join layer (see image 

below).  

 

Choose the join type that matches your preferred result in the joined layer.  

• One-to–one (takes attributes of the first located feature only); 

• One–to–many (creates a separate feature for each located feature). 

 

The resulting joined layer will be a new vector layer that is an extended version of the input 

layer. The new layer has additional attributes in its attribute table, based on the spatial 

criteria. If you do not want the records that did not match with your output layer, check the 

box for “Discard records which could not be joined”.  
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2.8.2 Vector joins  

Vectors may also be joined in the joins section of the layer properties. This is a way to associate 

data in one table with data in another. It may be used either between two vector layers or 

between a vector layer and a non-spatial dataset, such as a table. This is excellent if you have 

a table or spreadsheet you want to link with your existing spatial data.  

 

 

You can access it from the <Layer properties> in the tab <Joins>. Open it up for the layer you 

want as your input layer for the join. Select the join layer. Then select the field with unique id 

for both the join field and the target field, this is how the two datasets will be matched. All 

information from the join layer and the target layers will be displayed in the attribute table of 
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the target layer as joined information. If you only want specific fields added from the join 

layer, select them in “Joined Fields”. If you want to be able to edit join features from the 

target attribute table, you have to select “editable join layer”. 

 

Click <OK>. The join result will show in the Joins window. The selected fields will now appear 

when you open up the attribute table of the input layer.  

 

 
 

If you get no data (NULL) values in these fields, it means there was no overlap between the 

features. For instance, the turquoise vector layer (shown above) was chosen as <Input layer> 

and the brown vector layer was chosen as the <Join layer>. For turquoise features that do not 

overlap the brown features, the values of the join fields will be NULL. For the features that do 

have a spatial overlap, the values are shown in the joined fields. 

 

It is also possible to join a vector layer with a non–spatial layer. Select join field and target 

fields with unique ID’s. The data from the text file, is added based on the selected join fields.  
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2.9 QGIS Plugins 

Plugins in QGIS add useful additional features which enhance the software. Many contributors 

share tools that can simplify our work. They are written by QGIS developers and other 

independent users who want to extend the core functionality of the software. The plugins are 

made available in QGIS for all users.  

 

An easy way to browse and install plugins is to use the <Plugin Manager> tool. You can reach 

it from the menu: Plugins > Manage and install plugins. 

 

 

 

In the <All> tab, search for plugins in the search field at the top of the Plugins window. If there 

is a specific function you need, you can search for it. Often someone has created a plugin for 

the function you are looking for.  

 

Here is a list of some useful plugins that you may install or activate (for core plugins): 

• QuickMapServices (Collection of easy to hold basemaps) 

• Map Library (a map library which makes it easy to add much used maps) 

• Group Stats (Stats and anlysis for vector layers data) 

• Coordinate capture (activate it) 

• Lat Lon Tools (Tools to capture and zoom to coordinates) 

• Grass 7 (activate it) 

• GPS Tools (activate it) 

• Georeferencer (activate it) 

• Geometry checker (activate it) 

• Digitizing Tools (Subsumes different tools useful during digitizing sessions) 

• OpenLayers Plugin (Google Maps, Bing Maps, OpenStreetMap layers and more) 
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There are core plugins and there are external plugins. Core 

plugins are already part of the standard QGIS installation. To use 

them, you just need to enable them in the plugin manager tool. 

One of the core plugins is the Georeferencer GDAL, which will 

be described further down.  

 

Plugins are located into repositories. The default repository is the official one and is added to 

QGIS by default. This is the standard repository that you will be searching in when you enter 

the Plugin Manager tool. There are also some contributors that maintain their own repositories, 

and if you wish you may add them as well. They are available in the QGIS Plugins Repository 

and need to be installed by the users before using them. Two important ones are Boundless 

Plugin repository (http://qgis.boundlessgeo.com/plugins.xml) and GIS-Lab repository 

(http://gis-lab.info/programs/qgis/qgis-repo.xml). 

 

Click on Plugins > Manage and Install Plugins > Settings to add/change/remove repositories. 

 

 

 

 

 

Useful plugins 

QuickMapServices 

QuickMapServices is a very useful plugin in QGIS. It includes a collection of easy to add 

basemaps. Add it to QGIS from the Plugins repository: Plugins > Manage and Install Plugins. 

Search for it in the search field, and then choose “Install Plugin”. It will be available to you 

from the Web > QuickMapServices menu.  

 

http://plugins.qgis.org/
http://qgis.boundlessgeo.com/plugins.xml
http://gis-lab.info/programs/qgis/qgis-repo.xml
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Add the Open Street Map standard map: OSM standard. This is a very useful web service 

basemap. You may also search for available service maps from “Search QMS”. When you click 

it, you will get a window where you can search for available Web Map Services: 

 
 

In this example we have searched for services with the tag “forest”. The services marked with 

green are valid for use. You may filter out the valid layers in the “Filter by extent”. If you find 

a service of interest, click add to get it into the QGIS project. In the example below, we have 

added the service “Global forest cover loss 2000-2012”. 
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Map library 

Map library is another useful plugin, which makes it easy to add useful maps to your project. 

Add it from the Plugins repository. You will then get access to it from the Web-menu bar. Open 

it up and search for available maps. 

 

 
 

Group stats 

 
Simple statistics can be calculated from vector layers using the standard QGIS tools from the 

Vector > Analysis Tools > Basic statistics or Vector > Analysis Tools > List Unique Values 

menus. However, these are not sophisticated enough for summarizing the results of overlay 

analyses.  

 

The Group Stats plugin is useful for creating summary statistics about a dataset based on groups 

of features. It is similar to a pivot table in Excel. 

 

1. Click on Plugins > Manage and install plugins. 

2. In the All section, search for Group Stats and install the plugin. 
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3. One installed, Group Stats can be accessed from the Vector > Group Stats menu. 

4. Drag a summary field into Rows. 

5. Drag a function into Value. 

6. Drag the value to summarise into Value. 

7. Click Calculate to calculate the summary statistics. 
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3. Cartography and styling 

The cartographic functionality in QGIS is excellent and compares very well to 

features in ESRI ArcMap. QGIS offers advanced functionality to style your map just 

as you like it. In this chapter we will rapidly go through some of the most useful 

functionalities. We will use a combination of point, line and polygon layers. Make 

note that there are some small differences between the styling capabilities of each 

data type, but the functionality is similar for all.  

3.1 Single symbol style 

Right click the layer you want to style: select Layer properties > Symbology in the left 

selection. 

 

In this interface you can choose to symbolize all features with a single symbol. The marker is 

as a default a “Simple marker”. You may change the size and color along with other variables.  
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3.1.1 Changing the size according to the value of an attribute 

You can scale the symbol (for points primarily) according to the value of an attribute. Choose 

“diagrams” – “pie chart”. In the attributes field, you select an attribute that best represents 

the objects you wish to scale. Mark it and use the plus symbol.  

 

 

 

Then go to the size menu and select the scaled size. Select the attribute field that you want to 

control the scaling. Pay attention to what you are scaling: you can choose between area and 

diameter. Notice that you can also choose an “expression” which can be very useful for 

normalizing your data. Set maximum value to the max scale area. Then change the size and the 

minimum size for the scaled symbols. Hit “apply” and take a look at the resulting map. 
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3.1.2 Changing the symbol and style of vector symbols  

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

 

You can select more graphic symbols by changing the marker from a “simple marker” to a “SVG 

marker”. QGIS comes pre-defined with an array of different markers you can choose from. Each 

of these are scalable and customizable in terms of size, color, border color and rotation. Select 

the “simple marker” and choose “SVG marker” in the dropdown list.  
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Select an icon of choice—set the size, fill color, border color and border width. Choosing 

contrasting border and fill colors gives a better readability than similar colors, or single colors, 

and makes the icon “pop out” regardless of background or overlaps. Notice that the symbols 

are scaled according to the scaling set earlier. 
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3.1.3 Point clusters 

Point clusters can be useful for point representation, to make a map with many points more 

readable. It is mainly used in web maps/interactive maps. Decide yourself the distance for the 

points to cluster and the cluster symbol. The number in the cluster symbol tells about how 

many points the point is representing. When you zoom in the number will change and eventually 

all of them will be represented as single points. 
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3.1.4 Heat maps 

Another way of representing points are the use of heat maps. The darkest color in the map is 

representing the highest density of points in the map. You can choose the color ramp and the 

radius for the heat map. It is also possible to weight points by an attribute. 

 

 

 

 

 

 

3.1.5 Texture polygons 

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

 

Using patterns on areas to represent a value is a powerful cartographic tool. The benefit of 

clearly standing out, while at the same time allowing the background to shine through is often 

a much-desired effect in thematic map making.  

 

Open the <Layer Properties> and <Style> (or symbology) of the layer you like to visualize. It 

should be a polygon layer. Select the “Simple fill” and change it to a “Line pattern fill” using 

the dropdown as illustrated in the figure below.  
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Now you can control the pattern Angle, Distance (density) and Offset. Often a dense pattern 

is desired on smaller areas, while a bright color helps to make the pattern clearer. You can also 

change the type of line that forms the pattern. Try with different angles, like 0º, 45º or 90º. 

See that you can have overlapping areas and still retain readability by using a pattern with 

different color, angle and distance! 
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3.2 Classification and styling: standards 

Setting clear classification standards can help to make maps clearer to those who are viewing 

them. For instance, classification standards may define a set colour (RGB) and symbol for cities, 

roads, administrative boundaries, protected areas, or other frequently used features.  

  

 

3.3 Transparency 

Layers can be transparent, which allows you to see through the layer. This can be very useful 

when digitizing and also for visualization. Setting the transparency of the whole layer can be 

done using the Symbology > Opacity field (or Style > Opacity, in some versions) for vectors, 

or <Transparency> tab for raster layers. 
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3.4 Blending modes  

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

 

Blending is a graphical rendering technique. It is fairly advanced, and we will illustrate one 

useful mode. Experiment and read more on the subject in graphical text books and resources. 

It is a very useful technique to “magically” merge different overlapping layers into each other—

without using transparency! Often, blending modes is what takes a map from okay to excellent.  

 

Layer and feature blending are found in the <Symbology> (or <Style>) properties of a vector 

layer: choosing “Multiply” is often a good start. Notice how the icons now blend into the 

background (see below). 

 

With blending    

Without blending:  
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QGIS User Guide   |  M-1484 

54 
 

For a raster layer, the <Blending mode> is found under <Symbology> (<Style>), but the 

interface is a bit different: 

 

 

3.5 Color schemes: varying color according to 

attributes 

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

 

When making a thematic map, you would often like to use symbology that differs according to 

an attribute value of the object. This can easily be achieved using two different methods of 

colorizing the objects: Categorized scheme (also known as qualitative) or Graduated scheme 

(also known as quantitative). 

Categorized color scheme 

A categorized color scheme is used when you want to map unique values that do not compare 

directly, i.e. one value is not greater or lesser than another value.  

 

A perfect example is countries that we want to color differently. We start by choosing the 

<Categorized> scheme in the dropdown list (see image below). This gives us the option of 

choosing which attribute or expression should be used to categorize the data. For our country 

map we use “iso_a2” as the category. Select the <Color ramp> that you want to use and click 

<Classify> to automatically create rules for all values within the category we choose. Click 

<Apply> to apply the symbology to the map.  
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You can manually edit the rules and their labels by double clicking them. Try to play around 

with different color ramps. It is especially useful to add a new color ramp and use 

“ColorBrewer” or “cpt-city”— both offer expert-chosen and scientifically-funded color ramps 

that you can use directly (see image below).  
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Graduated color scheme 

When visualizing values that can be compared—e.g. count data, temperatures—you would use 

a graduated scheme. Graduated schemes are made to visualize ranges of values, typically split 

into classes so that you can visualize thousands of values within 5 to 9 color classes.  

 

1. Start by selecting the <Graduated> style.  

2. Select the attribute or expression you want to symbolize.  

3. Choose the number of <Classes> you want to have, and the <Mode> of which these 

classes are divided.  

4. Click <Classify> to generate the classes based on the actual values in the attribute you 

chose.  

 

Note: Pay attention to the fact that you should try only to use variables which have a relation 

to the area that they symbolize. Ideally, the value should be normalized to the area. This is 

often not the case, and sometimes you can skip this if you are sure you are getting the message 

of the map clearly across to the reader. You can manually adjust the class breaks by double 

clicking on the values and the legend entry.  
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3.5.1 Rule–based styling  

Rule-based classification or styling 

is useful for styling layers on the 

basis of more than one attribute.  

 

1. Open <Layer Properties>, 

and switch to the <Style> 

tab.  

2. Switch the classification 

style to <Rule-based>. 

3. Click the <Add rule> 

button. 

4. In the new dialog, click the 

ellipsis button <…> and add 

a rule in the <Expression 

string builder> window. 

 

 

 

For further information, visit: 

https://docs.qgis.org/2.8/en/docs/training_manual/vector_classification/classification.html.   

https://docs.qgis.org/2.8/en/docs/training_manual/vector_classification/classification.html
https://docs.qgis.org/2.8/en/docs/training_manual/vector_classification/classification.html
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3.6 Labelling 

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

 

Labelling is fairly easy in QGIS and can be combined with other symbology. A practical way of 

adjusting the position of labels is by making a dedicated point layer with an attribute 

“labeltext” and generate the points yourself.  

 

Labelling objects in an existing layer 

1. Go to <Layer Properties> and select <Labels>. 

2. Select which attribute the label text should come from (in the example below, this is 

BIO_CLASS). Click <Apply> and the labels are drawn.  

3. Below you find an array of customization options. There is not a one-fits-all solution—

but good practice is to use a “sans serif” text type (under <Text>), avoid overlapping 

and use <Buffer> with contrasting colors for clearer text. Text size can also be changed 

dynamically from an attribute value or expression. 

 
Creating layer definition files  

Layer Definition Files (.QLR) save all characteristics of a layer, such as its source, projections, 

spatial filters, styles and labels, so it can be reopened with these characteristics. Once a layer 

is setup with the characteristic you would like, right click on the layer and <Save as Layer 
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Definition File>. Layers can be added with their corresponding .QLR via Layer > Add from 

Layer Definition File.  

4. Creating new layers 

QGIS allows you to create new Shapefile layers, new SpatiaLite layers, new GPX 

layers and new Temporary Scratch layers. This can be useful when you are about 

to do some field work and wants to record your observations in a separate file 

before updating an existing dataset, for instance.  

4.1 Creating a new shapefile layer 

To create a shapefile layer:  

1. Select <Layer> from the menu, and go to Create layer > New Shapefile Layer.  

2. Specify: 
o The layer <File name>. 

o The <Geometry type>. It is important to select the geometry type that you 

want to work with (either point, line or polygon) as it will only allow you 

to add this geometry type to the layer 

o The coordinate system. 

3. Add attributes that you want to store along the objects (geometries), under <Fields 

List>. 

When you have created the new layer, it is automatically added to the layer manager. You 

are now ready to edit the layer and add features to it.  
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4.2 Creating a new file database and layers  

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

 

To create a new file databases and layers:  

1. Select <Layer> from the menu, and got to Create layer > New SpatiaLite Layer.  

2. Specify: 
o The <Layer name>. 

o The geometry <Type>. 

o The coordinate reference system, through <Specify CRS>. 

3. Add attributes that you want to store along the objects (geometries), under 

<Attributes List>. 

When you have created the new layer it is automatically added to the layer manager. You are 

now ready to edit the layer and add features to it.  
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4.3 Creating new temporary scratch layers 

Temporary scratch layers are temporary layers, which are not saved on the disk. They will be 

discarded when QGIS is closed. When you need to store features temporarily, or as intermediate 

layers during geoprocessing operations, they can be useful.  

 

Creating a temporary scratch layer:  

1. Select Layer > Create layer > New temporary scratch layer. You can also reach it by 

clicking this button:   

2. Specify: 
a. The layer name. 

b. The geometry type. 

c. The coordinate reference system. 

3. Select <OK> to create the temporary layer. Note: By default, it does not have any 

attributes. It is possible to add attributes to the layer from the attribute table. 
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4.4 Creating new layers from an existing layer 
Vector and raster layers can be saved in a different format or reprojected to a different 

coordinate system either by using the Layer > Save 

As menu or by right-clicking on the layer in the 

<Layers Panel>.  

Raster layers: 

Select Export > Save as.  

 

Vector layers: 

Select Export > Save Features As or Export > Save 

Selected Features As if you want to save only 

selected features. Make sure to check it before saving 

the layer. 
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5. Editing data 

Editing the data of a layer is fairly easy in QGIS. It is in particularly well supported 

when using a SpatiaLite file database. Select the layer you want to make changes 

to in the layer manager. In the editor toolbar click the “toggle editing” button. This 

makes the layer ready for editing.  

 

5.1 Add new feature 

To add a new feature, either go to the Edit dropdown list or select <Add feature> on the 

digitizing toolbar. Depending on the geometry type of the layer you are adding a feature to, it 

will either be:  

- Add Polygon Feature   

- Add Point Feature       

- Add Line Feature         

 

Now you can draw directly in the map window and digitize the object. When you are finished, 

click the right mouse button. If the layer has attributes, you will be prompted to input the 

values of these. Click <OK> and the feature is added to the layer. When you are finished with 

the editing, click the <Save> button and the <Toggle editing> button. The changes are now 

saved permanently to the data file.  

 

 



QGIS User Guide   |  M-1484 

64 
 

5.2 Node tool 

If you want to change existing objects you should use the <Node> tool. This enables you to 

change (move, add, delete) each node of the object. Activate the tool by clicking the <Node> 

tool button (see below) and click the red nodes that appear on the objects. Double clicking on 

the line adds a new node. Single click selects the node—you can then delete the node by hitting 

<Delete> on your keyboard.  

 

 

5.3 Snapping 

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

You can enable “snapping” when editing to allow you to easily “snap” onto existing vector data. 

This is very useful for boundaries and similar where you want the objects to have shared borders 

with zero distance between them. Enable snapping in the “snapping options” under settings.  
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5.4 Field calculator 

If your primary interest is in editing the attribute values, you should use the <Attribute table>. 

The attribute table allows you to edit values directly. Click <Toggle edit> and double-click on 

the values you want to edit.  

 

Another powerful tool is the <Field calculator>. This tool allows you to generate a new field 

on all objects with a value that is calculated based on an expression. The expression can consist 

of mathematical expressions, plain numbers and text, one or more of the objects attributes 

(fields) or a combination of either.  
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5.5 Advanced editing  

Enable the <Advanced editing> button (see below) to get access to more advanced tools for 

editing features. This tool can be used to create geometries based on exact coordinates and 

angles, and to do advanced geometry functions, such as adding a ring, merging features or 

rotation. The tools like <Rotate>, <Simplify>, <Add rings>, etc. are fairly self-explanatory. 

 

 

 

If you need accurate digitization where you require CAD-like control of the angles – you would 

use the <Advanced digitizing> tool. These tools add guidelines and snaps to angles, parallels 

and similar. You can also control the coordinates, angle and parallels with the hotkeys listed 

below.  

 

Note: You must have your project in a projected coordinate system for this to work. 
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5.6 Building a hillshade  

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

 

Usually, maps have a background layer to show 3D effects. This can be achieved in QGIS using 

a digital elevation model (DEM). This DEM keeps altitude values on pixels. 



QGIS User Guide   |  M-1484 

68 
 

 

 

In QGIS, Raster > Analysis > Hillshade is the solution for creating amazing hillshades. 

 

 
 

The settings are quite simple, only defining the input raster, output raster, position of the sun 

in azimuth degrees, the multiplying factor for elevations (used to exaggerate the altitudes) and 

the vertical inclination of the sun:  



QGIS User Guide   |  M-1484 

69 
 

 

 

Gives this output: 
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6. Vector analysis for problem solving 

One of the greatest strengths of GIS is spatial analysis. When it comes to making 

good and evaluated decisions, it is important to know the relationship and 

interactions between different features. GIS analysis combines attribute 

information and spatial information from geographic objects to find spatial 

patterns, find interactions between spatial data and to solve problems. There are 

a lot of different analyses to choose between. In this chapter, we will dive into a 

few of them. 

6.1 Processing Toolbox 

QGIS has a large variety of tools for spatial analysis. Many of the commonly used tools can be 

accessed from the main toolbar at the top of the window, through the Vector and Raster tabs.  

 

 

 

However, there are many other tools that are not available from here. To access these other 

tools, use the Processing Toolbox which is accessible through the Processing tab.  

 

You can search for a tool in the Processing Toolbox in the search tab or use the dropdown 

menus.  
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6.2 Buffer analysis 

A buffer analysis is often used to check whether an object affects its environment. A buffer 

consists of a calculated zone within a given distance from an object. You can do buffer analysis 

to points, lines and polygons. 

 

Example 1: You want no construction development to occur closer than 1,000 meters from a 

mangrove forest.  

 

Example 2: You know that seagrass locations are important areas for fish spawning. Pollution 

must never occur closer than 2,000 meters of these locations. 

 

Note: Buffering measures distances in meters, kilometres, feet, miles or yards. To get a 

correct result, the layer you want to buffer should first be saved in a projected coordinate 

system.  

 

6.2.1 Buffer in QGIS 

Choose the layer you want to buffer. It is also possible to buffer only a selection of the chosen 

layer. If so, first select the objects you want to buffer. Remember to mark the layer you want 

to select from before selecting. From the menu bar, select: Vector > Geoprocessing Tools > 

Buffer.  
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Choose correct layer. If you have selected features, make sure you check the box for “Selected 

features only”. Choose the <Distance> and unit for the measurement. In this case, the buffer 

distance will be 1,000 meters. Select <Run> to create the buffer. 
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Result: The dark blue layer represents the coral reefs, while the green is the buffer zone 

surrounding the coral reefs. The result of such a buffer analysis can be used in decision making, 

to avoid impact closer than a given distance.  

6.3 Overlay analysis 

Overlay analysis is a method that combines different themes to create new themes. Combining 

polygon layers is probably the most common overlay analysis of vector data, where the 

attributes of both layers are combined into one new layer. From the combinations of these 

attributes, new attributes can be calculated or classified. The most common overlay analyses 

are Clip, Union and Intersect. 

 

6.3.1 Clip 

<Clip> is an analysis that clips a vector layer using the features of another polygon layer. To 

do a clip analysis you need two layers. The input layer is the layer you want to clip. The overlay 

layer is the layer you use to do the clip.  

 

Example: You want a clip of all the observations (or other theme of interest) that are located 

inside one of the blocks in the ‘MM_BlockMap’ dataset. First you need to select the specific 

block in the blockmap layer. You can either save the selection as a layer for the analyses, or 

choose “Selected features only” when you are doing the clip analysis. This will be your clip 

layer (overlay layer).  

 

1. Make sure both the input and overlay layers are in the same coordinate system. 

2. Select the specific block of interest in the ‘MM_BlockMap’ layer. 

3. Select the clip function from the menu Vector > Geoprocessing tools > Clip.  

4. Choose the observations layer as your <Input layer> and the blockmap layer as the 

<Overlay layer>. 

5. Choose “Selected features only” to clip features only found within the specific 

block. 

6. Select <Run> to clip all of the observations found within the specified block, creating 

a temporary layer.  

7. If you are satisfied with the result, save the clip as a new layer.  
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The two red points are clipped from the observation layer by the selected block. 

 

 

6.3.2 Union 

The <Union> tool combines two layers into one, containing the attributes from both layers.  

 

This analysis can be used to check overlaps between features within an input layer. When it is 

used in this way separate features are created for overlapping and non-overlapping parts.  

 

 

Union for one layer (Source QGIS user documentation). 

The analysis can also be used to union an input layer with an overlay layer. In this case, each 

layer is split at its’ overlap with features from the other layer. The output from the analysis 

will be a layer which contains non-overlapping features from each of the layers and features 

for the parts that overlaps. The attribute table of the resulting union layer will contain attribute 

values from both of the original layers. Non-overlapping features gets attributes from its’ 

original layer and overlapping features from both layers.  
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Union between an input layer and an overlay layer (Source: QGIS user documentation). 

 

6.3.3 Intersect 

<Intersect> is an overlay analysis which computes which features or portions of features 

overlap in the input layers. The output intersection layer will have the geographic extension of 

the overlapping area, and its features will contain the attributes from both the input and the 

output layers. Intersection can be made between simple features: points, line or polygon.  

 

Intersect between an input layer and an overlay layer (Source: QGIS user documentation). 

6.4 Dissolve 

Dissolve is an algorithm which aggregates features in a vector layer by a common attribute. It 

may be used to dissolve boundaries.  

 

Example: You have a layer showing key biodiversity areas, which is divided into many features. 

You wish to have a layer that shows this information without the borders. You decide to dissolve 

the borders based on the attribute “kba_type”. Make sure the layer you wish to dissolve is 

enabled. Then choose Vector > Geoprocessing > Dissolve (see below). 
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Choose input layer and then which attribute/attributes you wish to use as the <Dissolve fields>. 

In this case we wish to dissolve the borders based on the attribute “kba_type”. Select this 

attribute, click <OK>, and select <Run>. 

 

    
Input layer     Output layer 
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Output geometries are converted to multi geometries. If the input layer is a polygon layer the 

boundaries of polygons are erased. If an attribute is chosen for the dissolve, the boarders are 

erased with basis in this attribute. 

 

6.5 Creating new layers from the result 

When you are doing different analyses in QGIS, the output layer you get is temporarily stored 

if a location to save the file is not identified before running the analysis. You may choose to 

save the layer immediately, but sometimes you will need to run an analysis many times before 

you are satisfied with the result. In this case, it is convenient to have the results as temporary 

files that are deleted when the project is closed.  

 

 

 

When you are satisfied with the result of your analysis you may export the temporary layer to 

a permanent file. Right-click on the layer and select Export > Save features as. You will then 

come to the “Save Vector Layer as…” window. Choose the path, filename, and coordinate 

system. If you want to add your layer to the map, choose “Add saved file to map”. Select 

<OK> to create a layer from the result of your analysis. 
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7. Raster Analysis 

Rasters represent the world using grid cells, where each cell has a distinct value. 

Each raster layer represents one attribute, while the level of detail depends on the 

cell size. By combining raster layers, we can create new layers with new cell 

values. This is the most common way of using raster analysis.  

 

7.1 Raster Calculator 

We will use two raster files to generate a new raster file that shows the change in values 

between these two rasters. The two rasters contain population data from the African continent, 

one for 1990 and the other one for 2000. Each pixel has population data assigned. Clicking on 

each pixel using the <Identify> tool will show its value. 

 

We first need to style these rasters, using the same process as that used for the vector files. 

We will style the only band on those rasters as “singleband pseudocolor”, “continuous 

distribution”. The aim of the analysis is to find the changes in population in Africa. So we need 

to find the difference in population between these rasters. 

 

Open Raster Calculator 

 
 

Like we did using <Field Calculator> for vectors, rasters can also build new pixels from 

operations. To find the difference in population, you need to subtract the 1990 raster from the 

2000 raster. This will subtract the overlapping grid cells from each other. The new raster will 

hold the difference between 1990 and 2000 for each grid cell. 

 

Double click on the raster for the year 2000 to add it to the expression. Then click the minus 

symbol in the operators section and then double click on the 1990 raster. Press <OK>. 
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Using the correct styling with the resulting raster layer can be very meaningful. So let’s change 

it to “singleband pseudocolor” and colour interpolation “discrete”. Four intervals would be 

used from the maximum to minimum value to represent neutral change, population increased, 

and population decreased. These values are available on Layer Properties > Metadata. 
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7.2 Zonal Statistics 
The <Zonal statistics> algorithm produces statistics based on raster attributes per zone (or 

location) within a vector layer. For example, you can generate statistics of altitude (from the 

raster layer) within each protected area (from a polygon layer). 

1. Search for and double-click on the <Zonal Statistics> tool in the processing 

<Toolbox>. 

2. Choose a raster layer for which to generate statistics (i.e. “DEM_Ngerengere_UTM” in 

the example below).  

3. Choose a polygon layer to use as the zones to generate statistics (i.e. “Clipped”). 

4. Select the “Statistics to calculate”.  

5. Select <Run>. 

 

6. Right-click on the vector layer you selected and open the attribute table. 

The tool has added additional fields (_min, _max, _sum, _count, _mean, _std, etc.) containing 

statistical summaries relating to the raster layer within each polygon.  
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8. GeoReferencing 

Many maps and images are scanned or similarly digitized and do not have a digital 

reference to a geographic coordinate system. This means QGIS does not know 

where in the world they are, and what extent they are covering. Georeferencing 

is the method by which we provide known points that “map” the scanned paper 

map to the digital map. The “paper map” can also be an aerial photo or similar 

format that lacks a georeference. To achieve this, we use the <GeoReferencer> 

tool in QGIS. ArcGIS users will be familiar with the concept and user interface.  

 

There are many different transformation types. Each has different properties. For most cases, 

you can safely use the <Polynomial 1> when georeferencing. This algorithm requires 3 or more 

<Ground Control Points> (GCPs) to link unique features on the paper map with the same unique 

features on the digital map. You should aim to have at least 5 to 8 GCPs spread across the map 

to ensure the best alignment, as each GCP will “pull” the map into place. 

 

There are two ways to georeference a map: either by entering the map coordinates, or from 

points in the map canvas. If you have a good and easily readable grid in your map, the use of 

map coordinates is the best method. If this is the case, use the coordinate system which the 

map is based on. For this method you will need 4 points, preferably the map’s corner 

coordinates. If they are difficult to read, use coordinates from the grid crossings. 
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If the grid is not detailed enough to read the corner coordinates or grid crossings, or if we would 

like to georeference an image without a grid, we use a method where we define GCPs on both 

the raster and in the map canvas. When we are georeferencing a map by defining GCPs in the 

map canvas, we should refer it to recognizable locations. This could be locations where country 

borders meet or locations where a river crosses a street, and so on. The important thing is that 

the GCPs are easy to locate both in the map you want to georeference and in the map canvas.  

 

Although some areas of the world do not have a lot of data available, there is often enough 

OpenStreetMap data to use for this purpose. In those cases, we use the <OpenLayers> plugin 

to view OpenStreetMap and use it as a reference for the tif. In Myanmar, a layer of the Country 

borders is available as a shapefile. We also have layers for railways, roads and waterways from 

OpenStreetMap that may be used to find good GCPs. 

 

Open the Georeferencer plugin in QGIS: 

If you are unable to find it here, you must first enable it in the Plugins manager, as described 

in the Section 2.9 (QGIS Plugins). 

 

 
 

Load the .tif image: 

 

 

 

You will be asked to fill in the information related to the coordinate system that is going to be 

assigned to the raster. Choose the coordinate reference system that fits best to the map’s 

regional zone. The raster maps of Myanmar are stored in .jpg files, and contain a grid with 
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geographic coordinates (WGS 84), measured in degrees. The EPSG is 4326. If you are working 

with projected maps, for example for maps in larger scales you would need to use a projected 

coordinate system instead.  

 

Note: In the case of Myanmar there are two different UTM zones onshore: one west of 96 

degrees (WGS 84/UTM 46N) and one east of 96 degrees (WGS 84/UTM 47N). The country 

standard projection is WGS 84 / UTM 47N. 

 

Once we have opened the <Transformation Parameters (Settings)>, select “Polynomial 1” 

(minimum 6 GCPs required), “Nearest neighbour” and run the transformation: 

 

 

 

Before you start georeferencing using the “from map canvas” method, make sure the project 

CRS is the same as the one of the raster map. If the map and the project CRS are different, you 

may get a bad result. 
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On the .tif file, there are 5 red points that will be used to match the chosen layer/layers in 

QGIS. Now, select the “Add Point” tool:  

  

Click into the first point and choose from map canvas. 

 
Search for the same point in the map canvas and click on it. This process will fill the coordinates 

fields needed for the next transformation. If something goes wrong choosing a point, we could 

move it or even delete it.  
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Once we have opened the <Transformation Parameters (Settings)>, select “Polynomial 1” 

(minimum 6 GCPs required), “Nearest neighbour” and run the transformation: 

  

 

Do not worry if you do not get the map totally correct on your first try. It can sometimes be a 

bit tricky to get a satisfying georeferenced result, especially if you are dealing with 

maps/images that stretch over more than one UTM zone. You can add and remove points until 

the result is satisfying.  

 

If you are georeferencing a map showing an entire country, you should use the available grid 

and georeference by entering the map’s coordinates. 
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9. Preparing for a report: printing and 

export  
Preparing maps for reports and printing is achieved in the <Print Composer> (or <Print 

Layout> in later versions). You can have several “composers” or layouts within a single 

QGIS project. You can also use the composers in other projects. This is very useful when 

you want to use the same style with different map content.  

 

Note: The screenshots in this section use an older version of QGIS; these will look slightly 

different in newer versions.  

 

You can also make “composer templates” of which you can base new composers on. Open a 

new print composer by clicking <New Print Composer> and add a descriptive name to the 

composer you are creating. 

 

 

9.1.1 Composition 

The first step is to choose the paper size and similar general attributes. These values are set in 

the “Composition” tab. Notice the “Print as raster” checkbox which we can experiment with 

later. 



QGIS User Guide   |  M-1484 

87 
 

 

9.1.2 Map item 

A print composer consists of multiple items. One item is the “map item”. You can have several 

map items in one composition, and each can be controlled individually. Add a map item by 

clicking “Add new map” and drag and drop the extent on the page where you would like the 

map to appear. 

 

 

  

In the “Item properties” tab you find all the details and controls on the selected item—in this 

case, the map item. We can control a lot of properties: perhaps most useful is the scale, 

rotation and extent. When you change anything, click “Update preview” to update the map. 
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In addition to controlling the extent by typing in the coordinates and scale number, you can 

also interactively navigate the content of the map item. You do this with the tool “Move item 

content” and drag-pan and scroll inside the map item to move the actual map content. 

 

When you are satisfied with the style and content of a map item – it can be useful to lock the 

map item for further changes. This can also be set to preserve the actual style of the map. 

You control this by the “locking” checkboxes: 

 

As mentioned, there is a vast number of possibilities in styling the map item, including adding 

grids, zebra-lines and coordinates on the border. Try out the different options in the map item 

properties: 
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9.1.3 Text items 

Text items are very useful for adding static text to the map. Adding metadata like projection, 

update date, data sources, name of the map maker and so forth is essential for a professional 

map. This can be added by using a “text item” in the composer. You add this by using the tool 

“Add new label”. For more control of the style you can also try the “add html frame” which 

requires some code for formatting.  

 
 

The content in a text item is controlled in the sidebar. You can add many text items in the 

same composer, and even add them on top of the map to “write” directly on the map.  
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9.1.4 Legend 

Legends are essential to convey the symbology of the map to the map reader. Legends can be 

automatically created in the composer by using the “Add new legend” tool. 

 

You control the content in the sidebar. You can choose to “Auto update” the legend, or 

manually control the legend items. The text and symbols are fetched from the layer manager 

in QGIS and controlled by the style manager which is presented in earlier chapters.  

 

Pay attention to the relationship between symbol size and legend icon size, which can cause 

troubles for large symbols. A practical tip is to avoid using the symbol size, but scale symbols 

in the map using the “Scale area” or “Scale diameter”. 
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9.1.5 Scale bar 

Adding a scale bar is a fairly straight forward task. You add it with the tool “Add new scalebar,” 

and control the appearance in the sidebar. Pay attention to the relationship between the “Map 

units per bar unit” and the “Segments” control.  

 

 

 

9.1.6 Exporting the map 

Exporting a map is done via the “export tools”. Mostly, you will want to export a PDF (“Export 

as PDF”) or a PNG. Notice that the dots-per-inch (DPI) and “print raster” affects the 

performance and results tremendously. You should also be aware that for large files QGIS will 

“hang” while the image is processed. Do not worry about this: QGIS is working, but is locking 

the interface for interaction. Be patient and it will finish after a while for large files. Save the 

results in the “Results” folder of your project folder structure. 
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9.1.7 Templates 

Using a map template 

 

Note: A set of Myanmar basemap templates, including administrative boundaries, are 

available in the Network Attached Storage system. 

 

When you want to make a new map composer based on a template, select the Composer 

manager > New from template > “Specific”, and choose the map template “qpt” file. Click 

<Add> and type in the name of the new map composer you are making. In the course material 

folder, you will find several templates which you are free to use directly or be inspired by. 

 

 

Creating a map template 

When you have designed a composition that you like, you should make a template of it that you 

can reuse and build upon. To make a composer template you choose the “save as template” 

option. This saves a “.qpt” file on the specified location. You should ensure that the resulting 

template file is copied to a centralized file share which allows you to efficiently share and 

manage the templates across the organization. 
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Make sure you include enough metadata in your map template. At a minimum, you should 

include the following information, noting that more information is almost always better than 

missing information:  

 

 

 

When you have finished your map template, you should incorporate routines in your 

organization to manage the map templates. Use the same routines as you would when sharing 

and managing your centralized databases: the benefits to the quality of reports and map 

products are tremendous.  

 

  



QGIS User Guide   |  M-1484 

94 
 

9.2 Creating an atlas from print composer 
Printing an atlas in QGIS involves printing several pages with maps in the same composer format.  

1. On the right side of the composer, there are three tabs: one of them is <Atlas 

generation>.  

2. Check “Generate Atlas” and some option will become active on this tab. 

 

3. The <Coverage layer> is the layer that will define those printed areas on each page of 

the atlas, such as a grid that covers the whole atlas. As you choose the coverage layer, 

select the map and check “Controlled by atlas” in its <Item properties> tab (see 

below). 

 

4. Back in the <Atlas generation> tab, a set of choices define the way we will name 

each file and page names (via “Output filename expression”). 

5. Below <Controlled by Atlas>, three options control how information is displayed:  (1) 

keeping a margin around each feature; (2) predefined scale in each page; or (3) fixed 

scale, which will keep the same map scale through all pages. 
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10. Appendix 

10.1  Work routines – best practice 

Data management and good work routines are essential in professional GIS work. Below, 

we review some good routines which should be followed. 

 

Basemap data, thematic map data and project-specific map data are three categories of data. 

It is very important to understand the difference between them, which we discuss further 

below. 

 

10.1.1 Basemap data, thematic data, and project map data 

Basemap data are those managed by other agencies: these are not changed, but used to make 

maps. Typically this can be country borders, administrative regions or similar. You should 

always make sure that you have requested the latest updated version of the data from the 

data owners. Ideally you should be able to get the data from a centralized source—such as a 

file share—where you can copy the data onto your local computer. Maintain metadata on the 

data, including the source, the date last updated, and any use constraints or licences. 

  

Thematic map data are those that you or your agency is responsible for changing and keeping 

up-to-date. You are the data owner: you manage the datasets, but other organizations use 

them as well. It is very important that your agency (as data owners) manage these data in a 

centralized location. In addition, you should have good routines when changing the data. If you 

need to change/update the data, one approach would be: 

 
1. Go to the centralized location where data are stored, and identify the dataset of 

interest. 

2. Add a line to a “sign out” text file (if this does not exist, make a new textfile). Write 

your name, address/phone/email, purpose, date, and time of the change. 

3. Copy the data to your local computer and update the data. 

4. Go back to the centralized location where the files are shared. 

5. Copy the old file into a folder named “archive.” 

6. Add a line to the “sign in” text file. Write your name, address/phone/email, changes 

made, date, and time the updated data were copied back into the folder. 

7. In the “sign out” text file, add a comment before your line with the text: “FINISHED”. 

8. Copy the updated data file back into the folder. 

This routine ensures that you have updated data in a centralized location with minimal effort. 

If such a work routine is not followed, you will soon have many different versions with changes 

in many different files, which will cause problems. These data should also be accompanied by 

metadata, outlining the source(s), the method of creation, the date last updated, and any use 

constraints or licences. 

 

Project map data are data which are specific to the project you are doing. This means that no 

one relies on this data. You should keep this data on your local computer and may have less 
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strict routines on managing this data. However, you should regularly make backups on file 

shares or USB sticks, and be prepared for any requests that may come for those data (including 

the accompanying metadata).  

 

10.1.2 Local file organization 

With professional GIS work, it is important to maintain good folder structure to control many 

files and many folders. We suggest the following folder structure for a project (illustrated 

with two projects): 

 

 

 

Keep your data in the designated folders. Use the “temp” folder for temporary trials and errors 

and scratch-data. Place all of your metadata documentation, notes, reports, map products in 

the “results” folder.  

10.1.3 Documentation and note-taking 

It is very good practice to start a project with a blank text file where you can write quick notes 

documenting what you are doing in the project. You can use this to make your report, and it 

gives you a good basis for teaching others to do this work. Some note-taking ideas: 

• Take brief notes of every step you do; 

• Use screenshots for documentation and note taking: 

o Use <PrintScreen> or Windows’ <Snipping Tool> to take screenshots. 

o Copy and paste code and snippets of data. 
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The Norwegian Environment Agency is working for 

a clean and diverse environment. Our primary 

tasks are to reduce greenhouse gas emissions, 

manage Norwegian nature, and prevent pollution. 

 

We are a government agency under the Ministry 

of Climate and Environment and have 700 

employees at our two offices in Trondheim and 

Oslo and at the Norwegian Nature Inspectorate’s 

more than sixty local offices. 

 

We implement and give advice on the 

development of climate and environmental 

policy. We are professionally independent. This 

means that we act independently in the individual 

cases that we decide and when we communicate 

knowledge and information or give advice. 

 

Our principal functions include collating and 

communicating environmental information,   

exercising regulatory authority, supervising and 

guiding regional and local government level, 

giving professional and technical advice, and 

participating in international environmental 

activities. 

Norwegian Environment Agency 

Telephone: +47 73 58 05 00 | Fax: +47 73 58 05 01 

E-mail: post@miljodir.no 

Web: www.environmentagency.no 

Postal address: Postboks 5672 Torgarden, N-7485 Trondheim 

Visiting address Trondheim: Brattørkaia 15, 7010 Trondheim 

Visiting address Oslo: Grensesvingen 7, 0661 Oslo 
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